[i2c] i2c: remove unused #include <version.h>

Jean Delvare khali at linux-fr.org
Mon Aug 25 09:49:23 CEST 2008


On Sat, 23 Aug 2008 09:45:44 +0200, Jean Delvare wrote:
> On Sat, 23 Aug 2008 13:56:04 +0800, Huang Weiyi wrote:
> > The driver(s) below do not use LINUX_VERSION_CODE nor KERNEL_VERSION.
> >   drivers/i2c/busses/i2c-at91.c
> > 
> > This patch removes the said #include <version.h>.
> > 
> > Signed-off-by: Huang Weiyi <weiyi.huang at gmail.com>
> > 
> > diff --git a/drivers/i2c/busses/i2c-at91.c b/drivers/i2c/busses/i2c-at91.c
> > index c1adcdb..9efb021 100644
> > --- a/drivers/i2c/busses/i2c-at91.c
> > +++ b/drivers/i2c/busses/i2c-at91.c
> > @@ -14,7 +14,6 @@
> >  */
> > 
> >  #include <linux/module.h>
> > -#include <linux/version.h>
> >  #include <linux/kernel.h>
> >  #include <linux/err.h>
> >  #include <linux/slab.h>
> > 
> 
> Applied, thanks.

Actually, Adrian Bunk sent this fix to Linus already, so I'm backing
out your version from my tree.

-- 
Jean Delvare



More information about the i2c mailing list