Call for 2.8.0 soon

Philip Pokorny ppokorny at penguincomputing.com
Thu Jun 12 17:51:53 CEST 2003


Jean Delvare wrote:
>>>- libsensors numbering because of binary incompatibility..... go to 
>>>1.5.0 or 2.0.0?
>>
>>What about going with 2.8.0...  Then track the lm_sensors version.
> 
> 
> Why that? There is no reason we number the lib version according to the
> package version. The lib compatibility is unlikely to change that often.

Actually, it is.

Anytime a driver is added to the library, the library version needs to 
change.  This is because the library has compiled in code for every chip 
that it knows about.  And the sensors executable has references to every 
chip that is supported by the matching libsensors.

I think the chances are high that at each release of lm_sensors, at 
least one new driver will be added...

This is also part of my motivation for trying to remove this coupling in 
  the "rewrite" of libsensors...

:v)

-- 
Philip Pokorny, Director of Engineering
Tel: 415-358-2635   Fax: 415-358-2646   Toll Free: 888-PENGUIN
PENGUIN COMPUTING, INC.
www.penguincomputing.com



More information about the lm-sensors mailing list