lm-sensors install goes fine, but I only get status of EEPROMs

Jean Delvare khali at linux-fr.org
Sat May 8 14:11:34 CEST 2004


> OK, my problem:  the install of lm_sensors seems to go fine. 
> Everything gets detected like it should, but when I run 'sensors', all
> I see are the EEPROMs.  I've check the FAQ entry for this and think
> I've done what it says to do--still no luck.  This is an Intel
> D865PERL board.  I don't know the specific sesnor ID , but they are
> detected as an SMSC EMC6D100 chipset...technical information is at 
> http://www.smsc.com/main/catalog/emc6d100.html#Additional%20Information.
>  
> If the lm85 driver isn't right for this chipset, and there isn't one 
> that is, I'd be glad to try to build a driver...I will probably need 
> some help on that.

The lm85 driver should support it. We have to find out why it didn't.

Please recompile with I2C chip debug turned on (it's an option in the
Linux configuration menu), then reload the lm85 driver and watch the
logs for hints.

You could also try using the force parameter of the lm85 module to force
it to accept your chip, and see how it goes:
  modprobe lm85 force=0,0x2e
Again, watch the logs for hints.

-- 
Jean Delvare
http://khali.linux-fr.org/



More information about the lm-sensors mailing list