[lm-sensors] i810/815 temperature sensor

Jean Delvare khali at linux-fr.org
Thu Aug 4 15:56:18 CEST 2005


Salut Jonathan,

> I am running a debian with 2.6.10 stable kernel recompiled with I2C
> Modules.

The debian kernel comes with all i2c modules AFAIK, so there is no need
to recompile it.

> john#lsmod
> Module                  Size  Used by
> i2c_dev                 8384  0
> 8250                   21812  0
> serial_core            18016  1 8250
> floppy                 53872  1
> vmnet                  26032  8
> vmmon                  44792  5
> eeprom                  6008  0
> i2c_sensor              3456  1 eeprom
> i2c_i801                9740  0
> i2c_i810                4068  0
> i2c_algo_bit            9192  1 i2c_i810
> i2c_core               20784  5
>                     i2c_dev,eeprom,i2c_sensor,i2c_i801,i2c_algo_bit
> unix                   22004  219

No temperature sensor module here.

> # Generated by sensors-detect on Thu Aug  4 11:55:45 2005
> # I2C adapter drivers
> i2c-i810
> i2c-i801
> # I2C chip drivers
> eeprom

Nor here.

Can you share the complete output of sensors-detect?

> I dont understand why no temperatures sensors are detected. Is it
> possible than my motherboard doesn't have any sensors ?

That's one possibility. Depends on the model, you didn't say what
motherboard model it was.

Another possibility is that the sensor is too new and sensors-detect
doesn't know about it. This is likely only if your motherboard is
relatively new and you use a relatively old version of lm_sensors.

The output of sensors-detect should tell.

--
Jean Delvare




More information about the lm-sensors mailing list