[lm-sensors] libsensors question

Johnathan Bunn darksage at gmail.com
Sun Aug 21 08:24:28 CEST 2005


I am sorry if this has been answered before ( I couldn't find any info ) or 
if this is the wrong list for this ... but if someone could please point me 
in the right direction it would be nice

okay so .. I wanted to write a little c prog using libsensors so that I 
could use it as a source for cacti, ( I am aware that there are some 
solutions available but this is for learning ) so heres my problem.

sensors_get_feature( chip name, number, *result )
gives me a seg fault, I am sure the chip name is right and I know the number 
is good because it gets the label... but beyond that I am baffled

I have attached my cpp file and an example output

thanks in advance

-- 
To follow the Path,
Look to the master,
Walk with the master,
See through the master,
Become the master
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lm-sensors.org/pipermail/lm-sensors/attachments/20050820/51898040/attachment.html>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: out.txt
URL: <http://lists.lm-sensors.org/pipermail/lm-sensors/attachments/20050820/51898040/attachment.txt>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: test.cpp
Type: application/octet-stream
Size: 1627 bytes
Desc: not available
URL: <http://lists.lm-sensors.org/pipermail/lm-sensors/attachments/20050820/51898040/attachment.obj>


More information about the lm-sensors mailing list