[lm-sensors] Fw: Processes causing CPU to overheat

Jon Roland jroland at linux-migration.net
Tue Aug 23 00:27:31 CEST 2005



-------- Original Message --------
Subject: Processes causing CPU to overheat
Date: Mon, 22 Aug 2005 22:11:41 +0000
From: Jon Roland <jroland at linux-migration.net>
Reply-To: jroland at linux-migration.net
Organization: Linux Migration Network
To: sensors at stimpy.netroedge.com
CC: Rob Ristroph <rgr at sdf.lonestar.org>, Les Nemeth <linuxles at yahoo.com>

One of my systems, with an Athlon 64 running Fedora Core 4, has developed an
interesting problem. With a temperature monitor I installed, the CPU runs at about
35 C normally, no matter what I am doing. But then, for no apparent reason, the
temperature rises rapidly to about 52 C and the system freezes, or sometimes
crashes. GKrellM shows a sudden rise in "nice usage" on the CPU and in both
processes and disk usage at the same time. Once the rise begins, I have only
seconds before the system freezes.

Attached are two frames from a log of top -b -c , the first from just before the
transition, the second from just after. Note the sudden appearance of ten perl
processes that consume about 10% of the CPU each.

I killed the first of those perl processes before the freezeup could occur, and
all the perl processes also died, the nice usage dropped to zero, and the CPU
temperature dropped back to the normal level of 35 C. I have since rebooted the
system, but the problem, which previously occurred after about a half-hour of a
session, has not returned, so far, after 10 hours.

We have been trying to figure out how 100 CPU usage could cause the CPU to
overheat. The only thing we can think of is that the processes might have somehow
turned off power to the CPU fan, or increased power to the CPU. Have you ever
encountered that kind of thing?

Where it gets interesting, and why I am contacting you, is that before I killed
that process, I could run sensors. Since then, when I run it, I get "No sensors
found!". I ran sensors-detect, and it seems to have run okay. Log attached. This
suggests to me that the process I killed has something to do with sensors.

Any comments or suggestions?

Please visit my website, http://www.constitution.org

-- Jon

http://www2.lm-sensors.nu/~lm78/support.html

----------------------------------------------------------------
Linux Migration Network   7793 Burnet Road #37, Austin, TX 78757
512/374-9585 www.linux-migration.net jroland at linux-migration.net
----------------------------------------------------------------

-------------- next part --------------
A non-text attachment was scrubbed...
Name: top_050822-00x.log
Type: text/x-log
Size: 20728 bytes
Desc: not available
URL: <http://lists.lm-sensors.org/pipermail/lm-sensors/attachments/20050822/997d9906/attachment.bin>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: 050822_sensors-detect.txt
URL: <http://lists.lm-sensors.org/pipermail/lm-sensors/attachments/20050822/997d9906/attachment.txt>


More information about the lm-sensors mailing list