[PATCH][I2C] Marvell mv64xxx i2c driver

Greg KH greg at kroah.com
Wed Feb 2 02:27:24 CET 2005


On Wed, Feb 02, 2005 at 03:15:14AM +0200, Alexey Dobriyan wrote:
 
> P. S.: struct mv64xxx_i2c_data revisited...
> 
> > +	uint			state;
> > +	ulong			reg_base_p;
> 
> Silly request, but... Maybe this should be changed to plain old "unsigned int"
> and "unsigned long". Please. I just don't understand why people use "uint",
> "u_int", "uInt", "UINT", "uINT", "uint_t" which are always typedef'ed to
> "unsigned int".

Not a silly request at all.  Please use the u32, u64 and so on values
instead.  That way we know what you mean, and it's portable.

thanks,

greg k-h



More information about the lm-sensors mailing list