Asus P4C800-E Deluxe/Winbond W83627THF issue

Rik Ryall wik at blueyonder.co.uk
Thu Feb 3 10:24:02 CET 2005


On Wednesday 02 February 2005 22:31, Jean Delvare wrote:
> Hi Rik,
>
> > I'm something of a noob to Linux (only two years...) so please
> > bear with me. :-)
>
> Not exactly my definition of the newbie, but nevermind ;)

Heh, twenty years of using and supporting almost entirely MS products tends to 
brainwash one -- besides, we never stop learning, right?
;-)

> > I'm running Suse 9.2 Pro with a 2.6.8 kernel (2.6.8-24.11-smp to be
> > precise)  and whilst I've made /some/ progress with getting sensors to
> > work, I seem to  be getting less positive results than I did on my
> > previous 2.4-based build.
> >
> > I'm getting it to see the sensor and it's giving some interesting
> > figures  despite tweaking and twiddling sensors.conf until I've gone
> > cross-eyed.
> >
> > I /think/ that CPU temp figure is a tad low and suspect it to be the
> > mobo  temp.
> >
> > I've tried issuing the "force_w83627thf:" parm when loading the
> > module,  however, I'm unsure of the array parms that should follow.
>
> FYI, this parameter is completely ignored by the w83627hf driver, both
> for 2.4 and 2.6 kernels. Cleaning this up is part of my todo list...
> among a dozen dozen other things, most of which have higher priorities
> ATM.

Fairy nuff :-)

> Anyway you clearly don't need this, the w83627thf is always correctly
> detected, and so is yours.
>
> > Also, despite setting the vid parm to 9.0, 9.1 and 10.0, I still can't
> > get rid  of the error...
>
> Which version of "libsensors" (and lm_sensors) is this? "sensors -v" and
> "ls -l /usr/lib/libsensor* /usr/local/lib/libsensor*" should tell. I
> think that the error on VID is caused by an old version of the library.
> For a 2.6.8 kernel, I think I remember you need at least lm_sensor 2.8.6
> (libsensors 3.0.4). If Suse backported some patches to their kernel, you
> might even need 2.8.8 (libsensors 3.0.6).

Ahh... I think you've possibly just hit the nail squarely on the head -- can 
you hear that?  That's the sound of me kicking myself, repeatedly.
:-)

wikkus at poochzilla:/etc> sensors -v
sensors version 2.8.7 with libsensors version 2.8.7

wikkus at poochzilla:/etc> ls -l /usr/lib/libsensor* /usr/local/lib/libsensor*
/bin/ls: /usr/local/lib/libsensor*: No such file or directory
-rw-r--r--  1 root root 155796 2004-10-02 02:14 /usr/lib/libsensors.a
lrwxrwxrwx  1 root root     15 2005-02-02 12:36 /usr/lib/libsensors.so -> 
libsensors.so.3
lrwxrwxrwx  1 root root     19 2005-02-02 12:36 /usr/lib/libsensors.so.3 -> 
libsensors.so.3.0.5
-rwxr-xr-x  1 root root 151981 2004-10-02 02:14 /usr/lib/libsensors.so.3.0.5
wikkus at poochzilla:/etc>

Sooo, I'm going to have to get down and dirty once more and do a little bit of 
compiling...

> > M/B Temp:   +125°C  (high =    +0°C, hyst =    +0°C)   sensor =
> > PII/Celeron  diode
> > CPU Temp:  +26.0°C  (high =   +80°C, hyst =   +75°C)   sensor =
> > PII/Celeron  diode
> > temp3:     -48.0°C  (high =   +80°C, hyst =   +75°C)   sensor =
> > thermistor
>
> I agree that the CPU temperature seems to be a bit low - however the MBM
> site confirms that CPU temp is temp2 in diode mode for this motherboard,
> so it would be correct. For motherboard you should set the sensor type
> to thermistor, and hopefully you would get a decent reading. You can try
> to switch temp3 to diode just in case, but most likely there's no third
> sensor so you can just add "ignore temp3" to your configuration file.
>
> If the motherboard BIOS displays some hardware monitoring information,
> comparing with what "sensors" reports is usually a good way to get
> things configured properly.

Good call, Jean. I checked what was being reported in the BIOS and was getting 
~29°C for the CPU and typically 5 or so °C less for the mobo.  I then went 
back into sensors.conf and tweaked a couple of things as suggested (temp1 to 
thermistor mode, temp2 to diode, ignore temp3) and got some more believable 
readings:

M/B Temp:    +30°C  (high =    +0°C, hyst =    +0°C)   sensor = thermistor
CPU Temp:  +25.0°C  (high =   +80°C, hyst =   +75°C)   sensor = PII/Celeron 
diode     

This is very positive stuff, although I think the labels for mobo and CPU need 
switching around.

Incidentally, I believe fan3 to be the PSU fan; still can't get anything from 
the CPU fan (it should be on fan0, as far as I can tell and is enabled with 
Asus' "Qcontrol" in BIOS), however, I'll not waste any more of your or my 
time 'til I've tried bringing the software more up to date.

> Hope that helps,

It certainly did, many, many thanks.

Will report back once I've had a chance to upgrade.

Kind regards, Rik.



More information about the lm-sensors mailing list