khali at linux-fr.org
Mon Jan 2 11:01:54 CET 2006
Jim Cromie wrote:
> This patch refactors SENSOR_DEVICE_ATTR_2 macro, following pattern set by
> SENSOR_ATTR. First it creates a new macro SENSOR_ATTR_2() which expands
> to an initialization expression, then it uses that in SENSOR_DEVICE_ATTR_2,
> which declares and initializes a struct sensor_device_attribute_2.
Looks OK to me, consider it applied. I won't push it until I am also
able to push a driver which uses it though (but that should happen soon
We should probably think of this part of the code and see what can be
done to improve it. struct sensor_device_attribute is currently
*larger* than struct sensor_device_attribute_2, which makes one wonder
if we shouldn't use sensor_device_attribute_2 everywhere even when we
don't actually need the second parameter. Also, the field names "index"
and "nr" are too generic IMHO and this might get confusing in the long
run. I was thinking of "channel" instead of "index". No idea for "nr"
though. Or maybe we are generic on purpose for reusability, but then
"index" and "nr" should be "nr0" and "nr1" or something equally
More information about the lm-sensors