[lm-sensors] [PATCH] lm75: Fix lm75a detection

Laurent Pinchart laurentp at cse-semaphore.com
Fri Apr 18 17:35:19 CEST 2008


Hi Jean,

On Friday 18 April 2008 16:10, Jean Delvare wrote:
> Hello Laurent,
> 
> On Wed, 16 Apr 2008 13:34:09 +0200, Laurent Pinchart wrote:
> > Philips LM75A temperature sensors don't pass the current detection check
> > as they return 0xffff when reading unimplemented registers instead of the
> > last read value. This patch modifies device detection to accept 0xffff as
> > valid values when reading registers 0x04-0x07.
> 
> In fact almost no LM75 clone mimics the original behavior perfectly so
> they all need to be forced with a module parameter at the moment. I
> have always been reluctant to update the detection code to support them
> all, as this would weaken it to a point where about any device at any
> of the 8 supported I2C addresses would be picked.
>
> May I ask on which system you have the Philips LM75A chip? If that's an
> embedded system where you will end up using the new-style lm75 driver,
> then I'd rather focus on getting this new-style driver ready, instead
> of updating the detection code.

This is indeed an embedded system. I'm fine with focussing on getting the
new-style driver ready.

Do you have more comments on David's patches ? He mentionned receiving no 
feedback on his smbalert# patch.

Best regards,

-- 
Laurent Pinchart
CSE Semaphore Belgium

Chaussee de Bruxelles, 732A
B-1410 Waterloo
Belgium

T +32 (2) 387 42 59
F +32 (2) 387 42 75
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.lm-sensors.org/pipermail/lm-sensors/attachments/20080418/ca339539/attachment.sig>


More information about the lm-sensors mailing list