[lm-sensors] it8712 rev 7; fan speeds reported incorrectly.

John Gumb john.gumb at tandberg.com
Tue Sep 16 15:53:54 CEST 2008


Jean

We have 3 monitored fans. They all showed the same behaviour.
I make absolutely no claims that rev 8 is correct - it just gets us out of a hole :-)

I'll resubmit the patch if needs be...would be good to get to the bottom of this first. If I get chance I'll have a look at the specs.

Best regards

John

-----Original Message-----
From: Jean Delvare [mailto:khali at linux-fr.org] 
Sent: 15 September 2008 15:29
To: John Gumb; Andrew Paprocki
Cc: lm-sensors at lm-sensors.org
Subject: Re: [lm-sensors] it8712 rev 7; fan speeds reported incorrectly.

Hi John,

Le lundi 15 septembre 2008, John Gumb a écrit :
> I've just picked up linux-2.6.27-rc5 and it would appear fan speeds are
> reported incorrectly now. We have it8712  rev7 on our systems. We see
> speeds of around 40K RPM (!!).
> 
> The following hack fixes it - it just punts 16 bit fan support out to
> rev8. It would appear our it8172 does not have 16 bit tacho support. Or
> if it does, the driver isn't enabling it properly.

Thanks for reporting. I don't have access to my collection of IT87xx
datasheets and personal notes on chip revisions, so I can't check
now. I will check when I am back home. Andrew, what do you think?

John, how many fans are monitored on your systems, and were they all
screwed up in 2.6.27-rc5, or only some of them?

> --- drivers/hwmon/it87.c.orig   2008-09-05 15:51:11.000000000 +0100
> 
> +++ drivers/hwmon/it87.c        2008-09-05 15:51:53.000000000 +0100
> 
> @@ -283,7 +283,7 @@
> 
>            IT8712F Datasheet 0.9.1, section 8.3.5 indicates 7h ==
> Version I.
> 
>            These are the first revisions with 16bit tachometer support.
> */
> 
>         return (data->type == it87 && data->revision >= 0x03)
> 
> -           || (data->type == it8712 && data->revision >= 0x07)
> 
> +           || (data->type == it8712 && data->revision >= 0x08)
> 
>             || data->type == it8716
> 
>             || data->type == it8718;
> 

Patch was totally destroyed by your mailer, so we can't apply it.
Please resend with HTML mails disabled or as a text attachment, or
whatever is needed for the patch to reach us in its original format.
We will also need a Signed-off-by statement from you as described in
section 12 of Documentation/SubmittingPatches.

Thanks,
-- 
Jean Delvare




More information about the lm-sensors mailing list