[lm-sensors] Starting up sensors failed

borat Gunter borat.gunter at googlemail.com
Thu Jun 24 09:10:59 CEST 2010


Hello Jean,

On Wed, Jun 23, 2010 at 2:38 PM, Jean Delvare <khali at linux-fr.org> wrote:

> On Wed, 23 Jun 2010 14:17:38 +0200, borat Gunter wrote:
> > Hello Everyone,
> >
> > i have done the *sensors-detect*, and the summary output looks like:
> >
> >  *Now follows a summary of the probes I have just done.
> >  Just press ENTER to continue:
> >
> > Driver `eeprom' (should be inserted):
> >   Detects correctly:
> >   * Bus `SMBus PIIX4 adapter at 0440'
> >     Busdriver `i2c-piix4', I2C address 0x50
> >     Chip `SPD EEPROM' (confidence: 1)
>
> If you see this, this means you are running a VERY old version of
> sensors-detect. So, try the latest version first [1], and then report
> again if it still doesn't work.
>
> [1] http://dl.lm-sensors.org/lm-sensors/files/sensors-detect
>
> >
> > I will now generate the commands needed to load the I2C modules.
> >
> > To make the sensors modules behave correctly, add these lines to
> > /etc/modprobe.conf:
> > #----cut here----
> > # I2C module options
> > alias char-major-89 i2c-dev
> > #----cut here----
> > To load everything that is needed, add this to some /etc/rc* file:
> > #----cut here----
> > # I2C adapter drivers
> > modprobe i2c-piix4
> > # I2C chip drivers
> > modprobe eeprom
> > # sleep 2 # optional
> > /usr/bin/sensors -s # recommended
> > #----cut here----
> >
> > WARNING! If you have some things built into your kernel, the list above
> > will contain too many modules. Skip the appropriate ones! You really
> should
> > try these commands right now to make sure everything is working properly.
> > Monitoring programs won't work until it's done.
> >
> > Do you want to generate /etc/sysconfig/lm_sensors? (YES/no):
> > insserv: can not symlink(../arkeia, rc2.d/S06arkeia): File exists
> > insserv: can not symlink(../arkeia, rc3.d/S06arkeia): File exists
> > insserv: can not symlink(../arkeia, rc4.d/S06arkeia): File exists
> > insserv: can not symlink(../arkeia, rc5.d/S06arkeia): File exists
>
> These errors come from your distribution and are unrelated to
> lm-sensors.
>
> >
> > *and then i tried to ignore these error message to start the sensors,
> > unfortunately failed.
> > *:~ # /etc/init.d/lm_sensors start
> > Starting up sensors:
> failed*
> >
> > Can somebody help me? What does insserv mean? And how to correct it?
>
> "failed" isn't descriptive enough for us to help you. You'll have to
> figure out which command in /etc/init.d/lm_sensors (which again is part
> of your distribution and not lm-sensors) failed.
>
> --
> Jean Delvare
> http://khali.linux-fr.org/wishlist.html




thanks a lot for your answer, I tried with the newest version of
sensors-detect that you suggested. And the output are:
# sensors-detect revision 5842 (2010-06-19 21:47:45 +0200)
# System: IBM eserver xSeries 345 -[867011X]-
# Board: IBM Not Specified

This program will help you determine which kernel modules you need
to load to use lm_sensors most effectively. It is generally safe
and recommended to accept the default answers to all questions,
unless you know what you're doing.

Some south bridges, CPUs or memory controllers contain embedded sensors.
Do you want to scan for them? This is totally safe. (YES/no):
Silicon Integrated Systems SIS5595...                       No
VIA VT82C686 Integrated Sensors...                          No
VIA VT8231 Integrated Sensors...                            No
AMD K8 thermal sensors...                                   No
AMD Family 10h thermal sensors...                           No
AMD Family 11h thermal sensors...                           No
Intel Core family thermal sensor...                         No
Intel Atom thermal sensor...                                No
Intel AMB FB-DIMM thermal sensor...                         No
VIA C7 thermal sensor...                                    No
VIA Nano thermal sensor...                                  No

Some Super I/O chips contain embedded sensors. We have to write to
standard I/O ports to probe them. This is usually safe.
Do you want to scan for Super I/O sensors? (YES/no):
Probing for Super-I/O at 0x2e/0x2f
*Trying family `National Semiconductor'...                   Yes
Found `Nat. Semi. PC8741x Super IO'
    (no hardware monitoring capabilities)*
Probing for Super-I/O at 0x4e/0x4f
Trying family `National Semiconductor'...                   No
Trying family `SMSC'...                                     No
Trying family `VIA/Winbond/Nuvoton/Fintek'...               No
Trying family `ITE'...                                      No

Some systems (mainly servers) implement IPMI, a set of common interfaces
through which system health data may be retrieved, amongst other things.
We first try to get the information from SMBIOS. If we don't find it
there, we have to read from arbitrary I/O ports to probe for such
interfaces. This is normally safe. Do you want to scan for IPMI
interfaces? (YES/no):
Probing for `IPMI BMC KCS' at 0xca0...                      No
Probing for `IPMI BMC SMIC' at 0xca8...                     No

Some hardware monitoring chips are accessible through the ISA I/O ports.
We have to write to arbitrary I/O ports to probe them. This is usually
safe though. Yes, you do have ISA I/O ports even if you do not have any
ISA slots! Do you want to scan the ISA I/O ports? (YES/no):
Probing for `National Semiconductor LM78' at 0x290...       No
Probing for `National Semiconductor LM79' at 0x290...       No
Probing for `Winbond W83781D' at 0x290...                   No
Probing for `Winbond W83782D' at 0x290...                   No

Lastly, we can probe the I2C/SMBus adapters for connected hardware
monitoring devices. This is the most risky part, and while it works
reasonably well on most systems, it has been reported to cause trouble
on some systems.
Do you want to probe the I2C/SMBus adapters now? (YES/no):
Using driver `i2c-piix4' for device 0000:00:0f.0: ServerWorks CSB5 South
Bridge

Next adapter: SMBus PIIX4 adapter at 0440 (i2c-0)
Do you want to scan it? (YES/no/selectively):

*Sorry, no sensors were detected.
*Either your system has no sensors, or they are not supported, or
they are connected to an I2C or SMBus adapter that is not
supported. If you find out what chips are on your board, check
http://www.lm-sensors.org/wiki/Devices for driver status.

It has different check result comparing to the old version, which should I
believe? And what else kann I do?

Best regards
Borat.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lm-sensors.org/pipermail/lm-sensors/attachments/20100624/cc6ceb0b/attachment.html>


More information about the lm-sensors mailing list