[lm-sensors] dme177737: pwm not working

Guenter Roeck guenter.roeck at ericsson.com
Wed Feb 23 21:33:17 CET 2011


On Wed, 2011-02-23 at 15:18 -0500, Juergen Bausa wrote:
> After upgrading from debian lenny (kernel 2.6.26) to squeeze (kernel 2.6.32) fancontrol 
> stopped working. I ran sensors-detect and I have the dme1737 module loaded,
> but pwmconfig says:
> 
> /usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed
> 
> I also noticed that while in lenny the dme1737 reported the found pwms in the log,
> there is no message from dme1737 under squeeze.
> 
> However, some controls are there:
> 
> jba at lisa:/sys/class/hwmon/hwmon1$ ll
> insgesamt 0
> lrwxrwxrwx 1 root root    0 23. Feb 21:01 device -> ../../../ATK0110:00
> -r--r--r-- 1 root root 4096 23. Feb 21:01 fan1_input
> -r--r--r-- 1 root root 4096 23. Feb 21:01 fan1_label
> -r--r--r-- 1 root root 4096 23. Feb 21:01 fan1_max
> -r--r--r-- 1 root root 4096 23. Feb 21:01 fan1_min
> -r--r--r-- 1 root root 4096 23. Feb 21:01 fan2_input
> -r--r--r-- 1 root root 4096 23. Feb 21:01 fan2_label
> -r--r--r-- 1 root root 4096 23. Feb 21:01 fan2_max
> -r--r--r-- 1 root root 4096 23. Feb 21:01 fan2_min
> -r--r--r-- 1 root root 4096 23. Feb 21:01 in0_input
> -r--r--r-- 1 root root 4096 23. Feb 21:01 in0_label
> -r--r--r-- 1 root root 4096 23. Feb 21:01 in0_max
> -r--r--r-- 1 root root 4096 23. Feb 21:01 in0_min
> -r--r--r-- 1 root root 4096 23. Feb 21:01 in1_input
> -r--r--r-- 1 root root 4096 23. Feb 21:01 in1_label
> -r--r--r-- 1 root root 4096 23. Feb 21:01 in1_max
> -r--r--r-- 1 root root 4096 23. Feb 21:01 in1_min
> -r--r--r-- 1 root root 4096 23. Feb 21:01 in2_input
> -r--r--r-- 1 root root 4096 23. Feb 21:01 in2_label
> -r--r--r-- 1 root root 4096 23. Feb 21:01 in2_max
> -r--r--r-- 1 root root 4096 23. Feb 21:01 in2_min
> -r--r--r-- 1 root root 4096 23. Feb 21:01 in3_input
> -r--r--r-- 1 root root 4096 23. Feb 21:01 in3_label
> -r--r--r-- 1 root root 4096 23. Feb 21:01 in3_max
> -r--r--r-- 1 root root 4096 23. Feb 21:01 in3_min
> -r--r--r-- 1 root root 4096 23. Feb 21:01 name
> drwxr-xr-x 2 root root    0 23. Feb 21:01 power
> lrwxrwxrwx 1 root root    0 23. Feb 21:01 subsystem -> ../../../../../../../class/hwmon
> -r--r--r-- 1 root root 4096 23. Feb 21:01 temp1_crit
> -r--r--r-- 1 root root 4096 23. Feb 21:01 temp1_input
> -r--r--r-- 1 root root 4096 23. Feb 21:01 temp1_label
> -r--r--r-- 1 root root 4096 23. Feb 21:01 temp1_max
> -r--r--r-- 1 root root 4096 23. Feb 21:01 temp2_crit
> -r--r--r-- 1 root root 4096 23. Feb 21:01 temp2_input
> -r--r--r-- 1 root root 4096 23. Feb 21:01 temp2_label
> -r--r--r-- 1 root root 4096 23. Feb 21:01 temp2_max
> -rw-r--r-- 1 root root 4096 23. Feb 21:01 uevent
> 
> Any idea, what I can do to solve this? I want my fancontrol back!

Do you see any related output with dmesg ?

Guenter






More information about the lm-sensors mailing list